Results 1 to 4 of 4

Thread: Dutchie joins the forum! (gen 1 Liberty/ Legacy build)

  1. #1
    n00b
    Join Date
    Aug 2014
    Location
    The Netherlands
    Posts
    2

    Default Dutchie joins the forum! (gen 1 Liberty/ Legacy build)

    Hello Guys,

    Im Dennis from holland, living in Hoogeveen(North) 20 years old and i got a passion for Subaru
    since when my dad bought a version 6 type RA (1999).

    About a year ago i bought a Legacy gen 1 2.0 GL (non AWD), i decided to swap al the parts from my crashed
    AWD Impreza. So it became a AWD Legacy, after a few months i sold it because i had constantly trouble with
    the battery and stuff. It dischargeded himself during the night, it made me crazy.
    I bought a WRX Wagon from Japan, after been with it on a 3500km holiday i decided
    i would like to drive a Legacy Turbo(or RS as you aussies call it )
    But the problem is, there are only 12 original Turbo's left in Holland, mostly hidden in a shed and when you get
    a change to buy one it will cost you 4000 euro's, whitch is a lot for a student ;)

    So, the guy who bougt the Legacy crashed it, so i can buy it back.
    Im thinking of selling my WRX and buying a crashed Impreza Wagon with what i believe is a STI engine(the onwner doesn't now either)
    with around 300bhp, plus some other cool stuff like, apexi boostcontroler, OZ rims, STI struts and springs etc.

    My plan it to build the STI engine into the Legacy, if it's possible with all the wirring stuff.
    Allso the brakes, diff, gearbox , Airconditioning etc.

    I would also install a RS bumper and Bonnet, spoiler and skirts.
    And a full respray.

    The Legacy


    Current Impreza


    Before i sold it


    If you guys are intressted in the build i post some photo's during the proces
    Sorry for my bad english


    Dennis

  2. #2
    Large member Ads's Avatar
    Join Date
    Apr 2005
    Location
    Sydney, Australia
    Posts
    988

    Default

    How is the build going? Did you end up going ahead with it?

  3. #3
    Advanced n00b
    Join Date
    Sep 2015
    Location
    Sunbury town, VIC
    Posts
    94

    Default

    Bad English? You're doing well mate!

    Interesting puzzle you've got there!

    If the Legacy battery is still draining make sure the light in the boot/trunk is turning off once the lid is closed.

    All the best with it!

    Cheers

    Bennie

  4. #4
    Member jimmyg's Avatar
    Join Date
    Oct 2004
    Location
    Bendigo Vic
    Posts
    286

    Default

    Build pics for sure please! Welcome
    What's an "RX" if you dont have a "W"! HeHe

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •