Page 4 of 4 FirstFirst 1234
Results 106 to 112 of 112

Thread: Fladric's pile of Subaru's

  1. #106
    Advanced n00b
    Join Date
    Feb 2008
    Location
    Italy
    Posts
    61

    Default

    Great pics as always Fladric!!!

    only 40 cm? we got 80cm in one day last friday that was funny. Not even with the hakkapelitta tyres there was grip

  2. #107
    Member jimmyg's Avatar
    Join Date
    Oct 2004
    Location
    Bendigo Vic
    Posts
    320

    Default

    What this ^^^^^ guy said. Living the dream.
    What's an "RX" if you dont have a "W"! HeHe

  3. #108
    Advanced n00b Fladric's Avatar
    Join Date
    Feb 2010
    Location
    Sweden
    Posts
    190

    Default

    Quote Originally Posted by Jumi_SPC View Post
    Great pics as always Fladric!!!

    only 40 cm? we got 80cm in one day last friday that was funny. Not even with the hakkapelitta tyres there was grip
    Haha, that is alot Got another 30 cm this weekend, I can't stop laughing

    Quote Originally Posted by jimmyg View Post
    What this ^^^^^ guy said. Living the dream.
    Thanks! Just wish I had more time, work takes too much time from my hobbies
    "If in doubt, flat out"
    Colin Mcrae

  4. #109
    Advanced n00b Fladric's Avatar
    Join Date
    Feb 2010
    Location
    Sweden
    Posts
    190

    Default

    Hi everyone!

    Long time no see!

    Been way too long since the last update, have been pretty busy so haven't found the time to update... Will get better I swear!

    Repaired the damage and got to the race.



    On site with the new front bumper.

    Pretty quickly i discovered that I still had temperature problems... Let the car cool down and took a sniff in the coolant tank. Baam. Exhaust smell and small bubbles!

    HeAdGaSkEt?!

    Went home and removed the engine, again.



    Removed the heads and found this:









    Broken head gasket and some detonation in one cylinder! Flow tested the injectors and the one on the damaged cylinder flowed bad, guess thats the detonation.



    Turbo gasket was pretty bad too!

    Sent the heads to be refurbished (turned out the were good so just got them resurfaced) and I sanded down the sharp edges on the piston that was bad and slapped it into the block again.

    Bought new parts and assembled the engine again.





    While the egine was out I cleaned the clutch fork, release bearing and the snout where it rest and gave them a good grease up again! Hopefully my clutch will operate smoother than it did

    Mounted the engine in the car and started it up with new fluids, worked like a charm!

    Before the next race i decided to replace my old rear subframe with a new, refurbished one from a newage STI!
    New paint and new bushings.





    Shiny

    That last race I did was a hillclimb event that I have done a few times before, lovely race!

    3 runs and counting the fastest time.



    On site before the race.


    Race went really well! Got really consistent times and made an improvement on my own tiem from last year with a little more than 2 seconds
    Car felt really well with the new rear bushings and subframe.
    Finished 2nd overall with 35 entrants. Very happy

    Some clips from the race:

    Run 1 incar:

    https://youtu.be/nCkCpumYKk4

    Run 2 incar

    https://youtu.be/0yRDYSV7Gyo

    Run 3 incar

    https://youtu.be/dybE0L3dYhA

    From the outside, run 2 (I think):

    https://youtu.be/07Q-zmrt274

    Nice thing was also that the temp kept stable during the whole day. Low and nice, lika a stock Legacy Turbo!

    Soon race time again, this weekend. Have started prepping the car to prevent dust from coming into the car, huge problems last year if you remember
    Will block all holes I can find and hope it is enough. Have been raining for a few days (got 40 mm yeasterday) so dust won't be a problem I hope!

    On other news, I bought another gen 1 Legacy Turbo This time a sedan, not tip top shape but pretty rust free and cheap








    I also got a deal on two EZ30 engines I couldn't resist I think one will go into one of my gen 1 Legacy Turbo wagons I have sitting that is missing it's engine.



    NA and E85 with some good headers would be pretty fun and different in a gen 1 I think

    That is all for now folks!
    "If in doubt, flat out"
    Colin Mcrae

  5. #110
    Advanced n00b Rslib72's Avatar
    Join Date
    Aug 2014
    Location
    Kelmscott wa perth
    Posts
    169

    Default

    nice one always enjoy these updates...

  6. #111
    Member jimmyg's Avatar
    Join Date
    Oct 2004
    Location
    Bendigo Vic
    Posts
    320

    Default

    Quote Originally Posted by Rslib72 View Post
    nice one always enjoy these updates...
    ^^^^^ What this guy said. So many old Subaru's I've lost count pages ago.
    What's an "RX" if you dont have a "W"! HeHe

  7. #112
    Advanced n00b Fladric's Avatar
    Join Date
    Feb 2010
    Location
    Sweden
    Posts
    190

    Default

    Quote Originally Posted by Rslib72 View Post
    nice one always enjoy these updates...
    Thanks!

    Quote Originally Posted by jimmyg View Post
    ^^^^^ What this guy said. So many old Subaru's I've lost count pages ago.
    Hehe, nearly me too Currently I have 11 gen 1 Legacy Turbo's...
    "If in doubt, flat out"
    Colin Mcrae

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (1 members and 1 guests)

  1. Usas

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •